Jump to content
Sign in to follow this  

statium plate trouble HELP!

Recommended Posts

Hey guys im installing my cycra plate today and having a little trouble. I got the 2 8mm bolts of the stock plate but I can't get the electric harness dissconected so i can free the bike of the light. Please help.

Also once disconeccted can I just leave it like that and wrap some electric tape around it and it won't short out other electric componets.

All help is much aprriciated

Share this post


Link to post
Share on other sites

there is a little tab where the light connects, push it outwards then put it out

Share this post


Link to post
Share on other sites
I just go it like right before you posted. That was freaking stiff tab.

Got it installed now.

What did you mount the top of the plate to? I just bought a Stadium plate, and haven't put it on yet. It doesn't seem like there's anything to mount the top tab to though...

-JP

Share this post


Link to post
Share on other sites

I didn't mount the top I just zip tied on right top corner over the bars, then ziptied both bottom corners to forks, and then drilled a hole ontop left corner can zippid it to the top of the forks. It loooks really nice even with 4 zip ties.

Share this post


Link to post
Share on other sites

should be able to secure it with only 3 zip-ties thats what i am using on mine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×