Jump to content
Sign in to follow this  

2007 yz250f clutch issues

Recommended Posts

Help Clutch issues

I have a brand new 2007 yz250f and after washing it todayI went to ride it and the clutch is not working. I canput it on the stand and put it in gear and it will engage the wheel however when you press the clutch it will not dis engage. I have tried rotating theclutch lever on the engine all the way up and it still will not disengage. What should I do. Is the clutch bad?

Share this post


Link to post
Share on other sites

The bike stand is not a good place to test your clutch action.

How does it feel when you're riding it? Does it not engage, disengage...???

Share this post


Link to post
Share on other sites

If it's brand new, take it back to the dealer and let them deal with it under warranty.

If you want to diagnose it yourself, first check the cable for correct adjustment (it's in the manual). I'm assuming you still have 'pressure' on the clutch lever and that its just not fully engaging the clutch when the lever is pulled. Chances are those adjustments will solve your problem. If not, take the clutch cover off and have a look.

Good luck.

Share this post


Link to post
Share on other sites

So I called the dealer and they said that it had no oil in it and that I just need to pop it and ride it and then it would start to work.... popped it down the drive way and rode it around the block and now it works just fine.

Thanks for the input.

Share this post


Link to post
Share on other sites
If it's brand new, take it back to the dealer and let them deal with it under warranty.

If you want to diagnose it yourself, first check the cable for correct adjustment (it's in the manual). I'm assuming you still have 'pressure' on the clutch lever and that its just not fully engaging the clutch when the lever is pulled. Chances are those adjustments will solve your problem. If not, take the clutch cover off and have a look.

Good luck.

Warranty? :lol: Sorry, not happening with "race" bikes. The dealer can cover it, but it's his decision. :applause:
So I called the dealer and they said that it had no oil in it and that I just need to pop it and ride it and then it would start to work.... popped it down the drive way and rode it around the block and now it works just fine.

Thanks for the input.

Share this post


Link to post
Share on other sites
My 06 YZ came with a 30 day warranty. I'd imagine its the same for the 4 strokes
You are right, Yamaha do offer a 30 day Factory Warranty. I didn't know that.

Share this post


Link to post
Share on other sites
You are right, Yamaha do offer a 30 day Factory Warranty. I didn't know that.

On my bike, I got an option 2 year warranty for seals, engine, and suspension stuff for an extra like $350. They wanted $1100 for it, but Im a good talker...

Share this post


Link to post
Share on other sites
On my bike, I got an option 2 year warranty for seals, engine, and suspension stuff for an extra like $350. They wanted $1100 for it, but Im a good talker...

They offered a warranty like that too me and I figured I would never use it DOH

Besides warranties are scams anyway

Share this post


Link to post
Share on other sites

Warranties are scams, you pay more then you will ever use. Insurance is a scam too, I could probably buy 2 new houses by the time I retire with the money insurance costs if I didn't have to pay insurance lol.

Now if Honda sold a motor warranty, that would be the greatest selling warranty in the history of the world..but probably make Honda bankrupt lol.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×