Jump to content
Sign in to follow this  

06 sm battery

Recommended Posts

Yeah I have the same issue. I was a retard and did not disconect my battery or put a charger on it I was just going to start it up every few days. Well I didn't so it was dead this spring I bought a charger and put it on it said it was charged and started but did not have enough juice to start the next day. I just does not seem to hold a charge now. Anyone have any ideas besides the new battery.

Share this post


Link to post
Share on other sites

i've had the same problem,charged it it started but the next day it was dead.charged it again and left it on the 2amp slow charge and it seems fine now but think i'm going to have to get a new one.

if the disply isn't coming on then theres no power getting there.when its on the charger turn the key on to see if the disply comes up.if it dosen't sounds like a fuse is blown

Share this post


Link to post
Share on other sites
I was just going to start it up every few days.

Not a good idea anyhow, assuming the bike is not being ridden when you start it up.

Share this post


Link to post
Share on other sites

DRZ batteries don't like to be deep cycled. I let mine go dead last year and it wouldn't come back to life, and did the same this year. Let it set too long in the fall without disconnecting the battery and it went dead. I recharged it back then and again today, but it wouldn't crank my bike over. It will get another new battery this year too.:applause:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×