Jump to content
Sign in to follow this  

Fcr problem HELP !!!!!

Recommended Posts

I just mounted a fcr carb from a yamaha 426. I put a Akrapovic full system on as well. It dousent start easy and when it runs it sounds like its backfiring.

Dousent idle either. Only runs with throttle. But it forsure dousent run properly.

Also i dont have the 3x3 airbox mod done. Would this be recommended after mounting an fcr?

Eddie plz help

Share this post


Link to post
Share on other sites

3x3 is recomended but not having it will not keep the bike from running. Check for anything that would keep fuel from making it to the motor while your waiting for Eddie to post :naughty: (idle jet, main jet, float height, etc).

BTW More info on your setup would be helpful (jet sizes, needle clip, fuel screw setting, etc) Good luck :bonk:

Share this post


Link to post
Share on other sites

I dont know anything about the jets. i just put it right on my bike and it was bloody hard to get it on. i would like to avoid taking it off. but if i have to i will. if someone could explain to me how to check the jets and the float and how do i tell what the jets are set to. i dont know what the fuel screw is either.

ps. a 3x3 mod should be cut out from the vent right below the seat right? should i just cut out a square right around the little vent breather.

Share this post


Link to post
Share on other sites

i have just fitted a fcr off yam 426, put emn needle 158 main jet 42 pilot jet 200 main air jet 100 pilot air jet fuel screw 1.75 turns out and runs great. had to adjust ap timing screw to get rid of the off idle bog.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...