Jump to content
Sign in to follow this  

Please help me.....

Recommended Posts

For starters I have a 1996 KLX 650.

I was out riding at the local mud hole and when I pulled out to head home my bike bogged down when I hit 4 grand.

When I got home I checked my spark plug for fouling and there was nothing. After that I ripped my carb and gave that a great washing then slapped it back in, same problem.

I finally broke down and took it to a shop and he fixed it, for a day. When i fired it up this morning everything semed normal and after it was warm enough I took off and when I hit 4 grand, it bogged down, again.:naughty::bonk::D

Im kinda desperate, all help is appricated.

Share this post


Link to post
Share on other sites

Sounds like you might have an ignition problem. The CDI could be bad, or not properly grounded. You'll probably want to go through the electrical system to make sure everything is dry.

If you've been in mud, you might have some packed in moisture in the electrical system.

Share this post


Link to post
Share on other sites

I know you said you pulled your carb, but it kinda sounds like the vent tubes might be clogged - any mud got lodged up in there and partially clogging?

Also, check fuel lines for any pinching or kinking as well as the fuel cap venting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...