Jump to content
Sign in to follow this  

sikk mx 141cc

Recommended Posts

I have a 06 sikk mx xl perimeter 125cc. I have been very impressed with this bike all around. It has taken everything I have thrown at it with no major problems. I recently was on ebay and found a 141cc kit for my 125. I was wondering if any of you guys have used this kit or heard anything about it. The 125 has plenty of power, but why not upgrade to a 141 for more power.

Share this post


Link to post
Share on other sites

Sounds good to me. But please make sure it will fit your motor. Check your bore and stroke are the same!!! If so, go for it!!!

Share this post


Link to post
Share on other sites

They guy selling the 141cc kit says it will fit on the motor. I am just worried about reliability and if it will wear out my clutch and tranny quicker.

Share this post


Link to post
Share on other sites
They guy selling the 141cc kit says it will fit on the motor. I am just worried about reliability and if it will wear out my clutch and tranny quicker.

I put a trail bike 140 kit on my sikk and it blew the clutch out.

Share this post


Link to post
Share on other sites

You can call sikk, and they will give you their new HD clutch kit. It has fixed that problem. there is another forum on the sikk reliability. Check that out also.

Share this post


Link to post
Share on other sites

How was the performance of the 140cc kit you had in your bike compared to the 125?

Share this post


Link to post
Share on other sites
How was the performance of the 140cc kit you had in your bike compared to the 125?

Started for a little while....cracked the head....hasn't fired since.....be cautious.....Sikk sucks.....and yes I own one too.

Share this post


Link to post
Share on other sites

The sikk motor is not the problem, apparently installing the 140 kit messed up your motor. How did you crack the head and why is that sikks fault if you installed the 140cc kit.

Share this post


Link to post
Share on other sites
The sikk motor is not the problem, apparently installing the 140 kit messed up your motor. How did you crack the head and why is that sikks fault if you installed the 140cc kit.

The "new" sikk motor is fine with the 5 plate clutch and oil slinger. T bolt sold me the 140 kit and said it would work, cat 5 ported the head. Some of the pros on here to me the head was overported. When I first installed the kit with cam piston and tb cylinder it ran pretty hot but still didnt have the compression a 140 kit should have. The tb kit says for chinese minis but i think it is made mainly for a gpx. The head gasket never really sealed up. I never said it was sikks fault. Thats clev, the kit is not on his bike but mine.

I have put this thing together 6 times with new gaskets, different heads and any thing else you can think of and it still doesnt run.

I am calling cooper friday and buying a xtreme pro stock 125 motor, you can bolt up all honda kits on it.

If i could do it all over again I would not buy a sikk. I would go with a pitster pro or xtreme.

Share this post


Link to post
Share on other sites

It sucks to go through a full custom rebuild and having it all go wrong. The kit I found fits the new sikk mx motor and requires no custom head work. It just bolts on using stock head and a new high compression piston along with the 141cc cylinder. Heres the link

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×