Help with a Husqvarna CR 50

I just bought a 1999 Husqvarna CR50 and I can't get the Kill Swithch to work and I traced the wires all the way until it goes into the case. Is there any quik fix. Does anyone have any experience with these bikes. I wish I could have got a KTM but the price was right for Husqvarna. Does anyone know of a good place to get Husky parts.

The kill button wire goes to the coil inside the ign. cover. The wire is probably broke just underneath the case. Very common on those & the older KTM 50s (same motor). Simply repair the wire or if beyond repair you'll need to replace the coil.

Thanks for the advice. The wire was broke just under the ignition cover. It is working fine now.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By pumpernickelBrad
      Hi Folks!

      Sorry if there are a bunch of threads already but I used the site's search function and didn't find anything so far...

      I just found a decent deal on a '14 350 EXC-F with 11k km (unknown hours). Has a few goodies including skid plate, hand guards and it's for sale for about $2k CAD less than a '16 with 6k km on it.
      The bike is in showroom condition (appearance) with no indication it has been offroad at all.

      What would be the gotchas that would make this deal realistic? I'm coming from a WR250R where the engine lasts forever, is 11k street kms high for these bikes? 
      Are there any big defects in the '14s that I haven't dug up yet?
      With no service records what things should be done, checked, etc?
    • By Brannnt
      I purchased an '06 525 EXC some time ago, and recently pulled the motor out of the frame to address some other issues. When I removed the clutch slave cylinder, I noticed an issue the previous owner neglected to tell me about during the purchase.
      It appears that at some point, the chain broke and damaged the engine case near the clutch slave cylinder (see pics, please). I have noticed that the clutch does not fully disengage (bike lurches a bit going into gear, neutral is hard to find... its worse when engine is cold) ... I did not notice any leaks around this area (mineral oil or engine oil) before or during disassembly. 
      The previous owner (or someone) repaired it with some sort of epoxy.
      Without doing my due diligence (checking clutch fluid level, bleeding) I hesitate to state that this is the cause of my clutch disengagement issue ... but pardon my ignorance here and help me out: How bad is this?  Am I looking at replacing my engine case here or is the previous owner's jerry rig good enough?

    • By Black Sox
      Just bought a new 2017 350 excf ,will be doing 98% off road ,ordered skid plate bark busters ,
      my ? Is what's the best easiest way to eliminate rear fender light assembly.I still would like to have a break light.
      xcf fender will fit so dealer says,under $50.00 👍But xcf brake light $125.00 .👎What's the best economical way of doing this?
    • By JNV
      Hi friends from Spain.
      Mi new KTM

    • By Brawg
      SO, for information sake and to power the search engines with some key words that i couldn't seem to trigger during my research...I'm posting my desmog process on my new 500exc. Being a new bike...i wanted to make sure that all of my "doings" were going to keep the short excuse for a warranty in tact. I have part numbers for the plugs, washers etc as well as what all came off of the bike. I know it's a simple process for some, not so for others and would like to give credit to the writeup for some great info.
      Long story short...i plugged the hole left from the smog pump thingy on the right side of the cylinder, the Secondary Air System (SAS), the overflow canister, and all the hoses/wires that go with. The electrical plug that was involved I simply taped up with grease in it and strapped it to the inside of the frame rail.
      After i took all of it off, it would not idle....i turned up the idle adjuster (to the left) or counter clockwise in order to increase the idle speed.
      Result!!!!!! NO popping on decal, no stalling after hard accelerating, etc. Sometimes after much creeping and low rpm riding it will load up and flame out. I plan to try a different map after i install my exhaust. I think a new map will be able to add some rev to the top end. Right now it seems kind've flat once you pull through the sweet bottom and mid ranges. The bottom end power of this bike coupled with the silky smooth clutch action makes for the easiest and best suited off road bike i've ever been on. It does what i need it to do!