XR650R valve adjust question

Is it normal for the right side exhaust valve to snap slightly when I turn the motor over with the kickstarter with the plug out when doing a valve adjustment? I assume this is the auto-decompress feature activating. Thanks

Auto decomp does weird things. Sounds normal. I ground off the rocker that rides on the decomp part of the cam to disable mine. It was easier than messing with the cam itself.

My XR650R seems to do exactly what you describe and only makes the noise when the auto decompression clicks in. Seems strange for it to make the noise - I thought I had done something wrong with adjusting the valves, but I rechecked and had another person recheck with me. Must be ok for it to make this noise, because I've ridden probably 500 miles since my last valve adjustment and everything seems to be ok.

So I'm having a problem just bought04 xr650r  bike with carb gummed up, cleaned carb, it started right up but while running its sounding like exhaust valve clacking it's so loud that I can hear it over exhaust it really annoying and I'm mechanically enabled never have done a valve adjustment but not scared but this is making me doubt my self if anyone could help that would be great and I'm in Rockaway beach Oregon I'll convert files and post video of it running or my instagram name is yash_and_dots

Mine did the same as the bike sat for a while before I got it. Mine would make the valve noise until you blipped the throttle to kick out the auto decomp. But mine only did it on the first cold start of the day, and over time it stopped altogether. I think turning up my idle helped this too.

4 hours ago, Adamthomas said:

Mine did the same as the bike sat for a while before I got it. Mine would make the valve noise until you blipped the throttle to kick out the auto decomp. But mine only did it on the first cold start of the day, and over time it stopped altogether. I think turning up my idle helped this too.

So I was thinking same thing but it definitely gets louder when rpm rise! I'm getting some feeler gauges today going to try to mess with the valves, fingers are crossed, if anyone knows how to make sure to not mess this up, I will disconnect manual decomp and check if there's play in valves so I'm not on auto decomp and that should be it then after that adjust manual decomp according to manual. If anyone can post a video of them setting there bike at tdc would be cool and just posted video on instagram of noise and I didn't blip the throttle but noise stays the whole time your riding

Edited by Yashixr650r

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now