Jump to content
Sign in to follow this  

Dr 650 wont start!

Recommended Posts

I just bought a new 08 dr650, now here is my problem: I decided to take it for a spin one night (ran fine) i got home and shut off the engine, i went inside for a bite to eat came back out to start it again and all it did was start clicking?!. The lights where still working so i thought it could'nt be the battery; but i thought i could be low so i charged it, i then put it back in and it started up. Now, today i started it up and it started fine, i then shut it off and tried starting it again, and it did the clicking thing again, What is wrong?!:thumbsup:

Share this post


Link to post
Share on other sites

Even new batteries can fail.

Being a new bike I would be talking to the dealer about it.

Enjoy your new DR! :thumbsup:

Share this post


Link to post
Share on other sites
Even new batteries can fail.

Being a new bike I would be talking to the dealer about it.

Enjoy your new DR! :thumbsup:

sounds like the battery... try tightening the battery terminals too.. may have loosened up...

Share this post


Link to post
Share on other sites
sounds like the battery... try tightening the battery terminals too.. may have loosened up...

Or they may have never been properly tightened by the minimum wage shop guy who took it out of the crate.

Share this post


Link to post
Share on other sites

Check all electrical connections. I had a loose wire that killed the engine when I was riding. It was a connection under the seat.

Share this post


Link to post
Share on other sites

I got a bad battery with my '07, dealer replaced it for free. If it is the battery... check the other stuff first: terminals etc. Also, make sure that when you take the key out and lock the bars that you only turn the key to "lock" and not past it to the parking light all the way the the left, it locks the bars and keeps the taillight on ( i killed a battery with that one).

Share this post


Link to post
Share on other sites

I have the same problem with mine, but only in cold weather. Mine is a 2007. It cranks fine when it's above 40 outside, but anytime it gets below that the battery just clicks and that's it. (Neutral light and other lights still work)

Any suggestions?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×