Jump to content
Sign in to follow this  

yz125 wont start

Recommended Posts

08 YZ125 put it up,always drain fuel 2 days later went to ride wouldn't start

Has good spark,getting fuel etc. just won't fire.Any idea's before I take to a dealer to fix ?

Share this post


Link to post
Share on other sites

How long has it been sitting? Try cleaning the carb and spraying out all the jets. Good luck and try and fix it yourself rather than the dealer, it's probably pretty simple.

Share this post


Link to post
Share on other sites

getting fuel? to what the float bowl? the combustion chamber? spark plug wet? if not clean the carb.. remember takes 3 things for an engine to run.. fuel..spark.. compression..

Share this post


Link to post
Share on other sites

How do you know it is getting spark?

Did you do the old take the plug out and stick it in the cap and kick it over trick?

If so, That's not sufficient evidence that it is getting "good" spark.

That just verifies that the pulse is getting to the spark plug.

A thin, weak or yellow spark out side of the combustion chamber doesn't mean that it is a strong enough spark to ignite the compressed mixture.

Have you tried a new plug?

Ride safe.

Ian

Share this post


Link to post
Share on other sites

bump start it and it HAS to start if it has gas, spark and compression/decent timing...if it runs good when you bump start it but wont idle, your pilot jet is clogged...dont take it to the shop...2 strokes are too easy to figure out...YOU CAN DO IT!!!! lol

Share this post


Link to post
Share on other sites

All things done,this is why I'm baffled it has compression,spark and is getting gas.Even took carb off and put hand over manifold to make sure it was sucking

Share this post


Link to post
Share on other sites
did you break it in rite?

Yes kid has been racing for quite some time and all bikes have been broken in

Thanks

Share this post


Link to post
Share on other sites
bump start it and it HAS to start if it has gas, spark and compression/decent timing...if it runs good when you bump start it but wont idle, your pilot jet is clogged...dont take it to the shop...2 strokes are too easy to figure out...YOU CAN DO IT!!!! lol

Tried that also no luck.This is the first time in a lot of years that I haven't been able to figure it out when a 2 stroke won't run.Even tried bypassing the kill switch just to make sure.This is bugging me as it has compression,fuel and spark

Share this post


Link to post
Share on other sites

Maybe it's just really flooded. Try taking the plug off turning the bike upside down and turn the engine over so any excess fuel can drain out. You would be amazed how much fuel can end up in that bottom end.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×