Jump to content
Sign in to follow this  

94 clutch slipping

Recommended Posts

My clutch is slipping slightly under hard exceleration.

Bike is standard with 2'' straight thru pipe and no other mods.

Iv'e had the clutch apart and verniered the plates with no apparent wear. It's very low miles for a 94 bike. Tried adjustment at cable ends too.

Anyone fitted uprated springs before ? Any ideas wot's causing the slippage ?

Share this post


Link to post
Share on other sites

:thumbsup:

My clutch is slipping slightly under hard exceleration.

Bike is standard with 2'' straight thru pipe and no other mods.

Iv'e had the clutch apart and verniered the plates with no apparent wear. It's very low miles for a 94 bike. Tried adjustment at cable ends too.

Anyone fitted uprated springs before ? Any ideas wot's causing the slippage ?

barnett makes really stiff springs maybe try that??? it worked for me...

Share this post


Link to post
Share on other sites

The bain of my life.

Tried the EBC heavy duty clutch kit, which included heavy springs.

Nice and soft feel, bulk slip in all gears.

The springs that were in the bike were twice as thick as the EBC springs, open it up again and put them back in and the thing still slips in 4th and 5th under full throttle.

Wont be getting another EBC kit again EVER, when money permits I will be putting OEM parts in.

Have heard that the early DR650's had an inherent problem with clutch slip, the clutch is redesigned in the 96-on bikes.

I have had it apart so many times, thinking I have installed it incorrectly, even went to the shop to get looked at. Their op was to get a new genuine clutch!!!!

Clutch didnt slip untill DJ kit, air box, exhaust and gearing were improved/fitted. So perhaps the clutch is on its limit while stock.

Share this post


Link to post
Share on other sites

Sounds just like the way I'm thinking about this problem ! thanks for the re-assurance. Ive had the clutch in bits twice and it's imaculate. Do you think the 2'' straight through muffler I fitted has boosted the h-power a bit more and just taken it over the edge ? I made it myself in stainless steel and thought I would have to mess about and re-jet n' stuff but it runs like a dream,ticks over peachy and fk-me is it LOUD !!! It's actually startin to pss me off alittle....jeez I never thought i'd say that but youd probably agree if you heard it. Maybe I should try and post a sound bite !

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×