Jump to content
Sign in to follow this  

03yz250 clutch slipping problem

Recommended Posts

Ive replaced the plates n springs with a ebc kit. It still slips at high rpm under a load, ei deep loam or pavement. I use honda hp gear oil. Ive used this oil for 15 years and never had any problems with clutches.Its not my cable because I dont have one, its hydralic,yes the cylinder is releasing fully.Any suggestions will be greatly appreciated,thankyou

Share this post


Link to post
Share on other sites
Ive replaced the plates n springs with a ebc kit. It still slips at high rpm under a load, ei deep loam or pavement. I use honda hp gear oil. Ive used this oil for 15 years and never had any problems with clutches.Its not my cable because I dont have one, its hydralic,yes the cylinder is releasing fully.Any suggestions will be greatly appreciated,thankyou

When did you first notice it sliping, before or after the hydralic? Did your old plates look worn? Did you replace all the plates or just the friction plates?

Share this post


Link to post
Share on other sites

is there an adjustment on the end of the pushrod at the basket?

You could try shimming your springs for a bit more preload. The crush washers off old spark plugs work well for most bikes.

Share this post


Link to post
Share on other sites

Thanks for the input, but its gonna take a lil more then that.My springs are shattered.Any idea what caused that? They're only a few hours old.My guess is ebc had a bad lot of springs but i could be wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×