cant get cam chain back on

i accidentaly popped my cam chain off and cant

seem to coax it back on. does anyone have any tips for me?

Release the cam chain tensionor...

Release the chain tensioner, take the cam cap off of one cam (if it is a double cam), tip the cam up and put the chain on, put the cam cap back on and put the tensioner back in.

REMOVE the cam chain tensioner, what model bike is this??

REMOVE the cam chain tensioner, what model bike is this??

rmz 450

Release the chain tensioner, take the cam cap off of one cam (if it is a double cam), tip the cam up and put the chain on, put the cam cap back on and put the tensioner back in.

yes it is a double cam and i took the chain tensioner completly off because

i couldnt loosen the bolt on the end:excuseme: im not exactly sure how those tensioners work

Be careful installing that tensioner again, it has to be turned in before install or else you'll crank your cam chain way too tight - well, actually you'll probably break something....

Do as KJ said, the chain isn't long enough to go over while the cams are installed, it's a half and half deal you get a little slack on the chain and you get a little slack on the cam gear when you tilt it because the gear moves down some - you might have to do both cams in unison to slip it back on depending on the bike...

Be careful installing that tensioner again, it has to be turned in before install or else you'll crank your cam chain way too tight - well, actually you'll probably break something....

Do as KJ said, the chain isn't long enough to go over while the cams are installed, it's a half and half deal you get a little slack on the chain and you get a little slack on the cam gear when you tilt it because the gear moves down some - you might have to do both cams in unison to slip it back on depending on the bike...

i got the cams and chain back on and then i put the tensioner back in after, but now when i try to kick over my bike the cams dont move and seem to get jammed and doesent move, i dont know what the problem is ??

your cam timing is probably off- hopefully you didnt ben a valve. Dont you have the service manual they come with? What year is the bike? They switched from a manual cam chain tensioner to an auto one- they have completely different procedures for resetting.

sorry man but it sounds like your way over your head you really should bring to someone who knows what they are doing before you cause some very expensive damage!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now