Jump to content
Sign in to follow this  

Timing Help On A 85 XT600

Recommended Posts

I have an 85 XT600 and it pings pretty dang bad. I was hoping I could just adjust the timing but there is no adjustment. Anybody know what could cause it to ping? What about it being lean? How can I richen it up, I am not familiar with these old bikes. I am assuming it is basically the same as the newer stuff like my kx450.

Share this post


Link to post
Share on other sites

Chances are that it is your valves that need adjusting. The specs for intake is .07mm - .12mm (.0028 - .0047 in) for the intake and .12 - .17mm ( .0047-.0067 in) for the exhaust. Do it first thing in the morning before any start up, according to the Clymer manual.

Share this post


Link to post
Share on other sites

I did check and adjust them. So they are fine. It does have HC piston in it. It has the wisco 11.5 to 1 in it.

Share this post


Link to post
Share on other sites

Well, theres your problem, the HC piston. You are running high octane, right? May even need octane booster. Air cooled engine are much more particular when it comes to compression ratio bumps than water cooled engines. Excessive carbon build up can contribute too.

Share this post


Link to post
Share on other sites

Yeah I have high octane (at least premium) in it. I don't get why people put stuff like this in a freaking dual sport, at least one that should be running on pump gas no problem. I hope its something simple like jetting. Ill have to tear the carbs apart and see what its got for jets.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×