Jump to content
Sign in to follow this  

Speedo Problem

Recommended Posts

Hey everybody! I've looked through other posts but can't seem to find my exact problem. A few weeks ago my speedo cluster started blinking on and off rapidly. Thought it was a loose battery connetion but it wasn't. Then I traced all my other connections to the speedo and eveything seems tight and where it should be. Now it's completly blank, the backlight comes on but I have no digital display. I really don't care much since I have a great GPS so my question is this; should I try to fix this one get a replacement OEM or say screw it and get a good endro type? Thanks in advance. :)

Steve

Share this post


Link to post
Share on other sites

Low voltage to the display will cause it to flash, or not display, have you taken voltage readings to the unit? There are lots of reasons for low voltage.

Share this post


Link to post
Share on other sites

William,

I am pretty good with a souldering gun. I also fly RC Planes. I'll open it up tonight and see if it's loose. Thanks for the advice.

Steve

Share this post


Link to post
Share on other sites

I had the same problem and it was a soldered connection that came loose on the circuit board. This is likely your problem. It is fairly common. There is a transitor on the board that vibrates loose. It can be soldered back. I podded mine in epoxy after I soldered it to help prevent the same problem in the future. Here is link to a thread with info.

http://www.thumpertalk.com/forum/showthread.php?t=427002&page=2

Share this post


Link to post
Share on other sites

Sorry, don't remember the colors but when you check for voltages, it's either 12v or not, anything else is not correct. Just follow the wire from the display to the connector. There will be an "always on" power supply (memory) and a "key switched on" power supply. Without the bike running, it should read the same as the battery, very little voltage drop might be ok but a lot of drop is an indication of a wiring issue that supplies the voltage to the display

http://www.thumpertalk.com/forum/showthread.php?t=627314&highlight=Flickering+digital+display

This is a thread about my flickering display. Take some readings before you open up the display.

HTH, good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...