Jump to content
Sign in to follow this  

I've tried everything - blurping at mid throtle after exhaust change

Recommended Posts

Hi guys, I installed the FMF 4.1 with Megabomb to my WRF 250 2007 and jetted it with the JD Jetting Main jet 175.

The problem: it idles ok, but as you start accelerating it begins to missfire and random fire until you accelerate full throtle where it picks power and stops missfireing.

The bike has the air induction system disconected and the CDI gray wire cut.

IT has POWERWING from Boyesen.

I changed the spark plug for a CR9EIX NGK iridium plug. Tested and problem kept going on so I took out the spark plug and noticed that the plug was black almost inmediatly.

Even the new exhaust is full of carbon black.

The bike fires horrible between 1/4 and 1/2 throtle.

I've done averything I know but still dont get it to run properly.

I even tried a New CDI unit. And a new ignition coil I borrowed.

The needle is in the third grove from top

I have a needle from FMF power jet kit and the MAIN JET is from JD JETTING KIT. Is it possible that the NEDDLE and JET combination is not COMPATIBLE?

Please give some advice on how to solve this out.

Thanks

Mr Pink

Share this post


Link to post
Share on other sites

hi,, i have the same trouble men,, with rmz 450 07

just blow a hole in my new carbon muffler (fmf) i put the same main jet went 175 but the bike just didnt stop missfireing at desaceleration.

just dont what else i can do,

maybe moving 2 turns at air screw.?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...