Jump to content
Sign in to follow this  

2004 rmz wont rev just backfires

Recommended Posts

Help....I bought a 2004 Rmz250 with no engine, I pieced together an 05 rmz250 engine, this thing fires right up and idles like a champ, revs ok up to 1/4 throttle then anything over that it , SOUNDS LIKE A REV LIMITER KICKS IN, I have checked the : Timing Marks, had the intake cam re-indexed and welded, exhaust cam is good, loads of compression, new spark plug, checked jetting, disassembled entire carb - cleaned - set up rich, tested stator and crank sensor - resistance ok, reset the timing marks a zillion times, cant figure this one out....Any help would be great...Thanks

Share this post


Link to post
Share on other sites

Most parts are the same on a 2004-06 RMZ 250. However, the 04 has many motor and electrical parts with different #'s from the 05's and 06's.

Because you have a 04 electrical system and a 05 motor, that might be your problem. If the CDI is for an 04, it won't work on a 05 motor.

I have a 2004 RMZ250 that will start, run up to about 25%, but then stalls out after.

I've tried everything to get it going, including switching up the CDI. I tried an 05 CDI on my 04 and it just backfired a bunch of time...different map.

I'd make sure the CDI is for an 05, as well at the electrical system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...