Jump to content
Sign in to follow this  

z50 runnin like $H!* wont run unless choke is on.

Recommended Posts

the choke has to be fully opened for it to run

it is a 93 Z50. everything is stock. I just adjusted the valves and the timing

to get it running, but now it won't idle or anything.

I have cleaned the carb

adjusted the idle while it was running.

adjusted the throttle cable.. nothing

and half the time when i rev it up it will bog down and die unless i let off the throttle.

im stumped.

Share this post


Link to post
Share on other sites

It's likely the pilot jet circuit is clogged, you need to use contact cleaner to flush out all the passages and circuits, and blow them out with compressed air. The pilot jet itself is not removable, so you might do well to have the carb cleaned ultrasonically, to get rid of the gummy deposits.

Share this post


Link to post
Share on other sites

could it be anything else?

i will try cleaning again

i have cleaned it with carb cleaner and compressed air pretty good recently

Share this post


Link to post
Share on other sites

The pilot jet controls the fuel delivery from idle to 1/4 throttle, running with the choke on makes for an excessively rich condition (due to the severe restriction of air). If that is clogged you are not getting enough fuel to let the bike run, creating a very lean situation. If you've cleaned the carb to your satisfaction, then you might want to consider getting another carb, and one from a CRF/XR50 is a direct bolt-on. They are readily available, everyone goes to a bigger carb once they install a big bore kit.

Share this post


Link to post
Share on other sites

i also have a z50. it will start up first kick and idle.....but as sooon as you give it any throttle its bogs down and stalls. I have strong spark, my timing is correct, and i am getting good fuel flo. I have no idea what the problem is. please help.

Share this post


Link to post
Share on other sites
i also have a z50. it will start up first kick and idle.....but as sooon as you give it any throttle its bogs down and stalls. I have strong spark, my timing is correct, and i am getting good fuel flo. I have no idea what the problem is. please help.
Pull and clean the carb, make sure you can clearly see through all the jets when you done. Wouldn't hurt to check the points and the valves clearance while you have your tools out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...