Jump to content
Sign in to follow this  

pw 50 help

Recommended Posts

i bought a pw 50 today for 50 dollars got it to run its old don't now the year engine runs good but wont pull my son the bike wont even pull its self but when i put it on the stand the tire turns fast and works good but when my son gets on it. it don't run saw that it was shaft driven new to that maybe it needs some adjustments

Share this post


Link to post
Share on other sites
i bought a pw 50 today for 50 dollars got it to run its old don't now the year engine runs good but wont pull my son the bike wont even pull its self but when i put it on the stand the tire turns fast and works good but when my son gets on it. it don't run saw that it was shaft driven new to that maybe it needs some adjustments

did you turn the handlebar switch from start to run?

check the 2 shoe clutch pads for wear

Share this post


Link to post
Share on other sites

yes i switched it to run were are the clutch shoes

Share this post


Link to post
Share on other sites

yes or i get off the bike it bogs with its own weight but when i put it on the stand it runs great

Share this post


Link to post
Share on other sites

I would say that it either needs a top end or clutch springs or both. Cluch shoes and springs are under the right side engine cover. You have to remove the engine from the frame to get to it. At least you have to unbolt it and move it forward.

Share this post


Link to post
Share on other sites

not sure how i fixed it but the next day when i started it it ran

Share this post


Link to post
Share on other sites
did you turn the handlebar switch from start to run?

check the 2 shoe clutch pads for wear

it was probably the switch sticking they are famous for going bad, keep an eye on it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...