Jump to content
Sign in to follow this  

Weird fuel flow issue...

Recommended Posts

Hi All. I've got a weirdness issue I thought I'd run past you on my 2000E. When I first bought the Z back in 2000 I immediately put one of those clear in-line fuel filters on it just before the carb (because I'm paranoid like that).

Anyway, my question is: how come the fuel filter doesn't stay full? When the engine is running, it eventually gets to where the filter looks empty. When you look closer there's just a very little bit of fuel in the bottom of the filter. It runs fine though and it's always done that. If you take the fuel line loose from the carb, the filter instantly fills up and gas absolutely pours out the line. After you reconnect and run the engine a little, it goes back to almost empty again though :) . If I forget and leave the petcock in the 'on' position while the bike sits for a while it fills the filter back up too.

I guess it's a non-issue really, but it's kind of disconcerting seeing the filter empty. Is there some kind of back pressure on that line from the carb? Anybody else see this? :D

Share this post


Link to post
Share on other sites

I've seen that on every clear fuel filter I have ever put on. On cars too. I guess it's normal?

Share this post


Link to post
Share on other sites
Hi All. I've got a weirdness issue I thought I'd run past you on my 2000E. When I first bought the Z back in 2000 I immediately put one of those clear in-line fuel filters on it just before the carb (because I'm paranoid like that). :

Your not paranoid, ive done that too, noticed the same thing, but I dont worry about it! but it was difficult to get a filter small enough to fit in the space between the tap and the carb!

dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...