Jump to content
Sign in to follow this  

HELP!! Engine kill button not working

Recommended Posts

I tried doing a search and couldn't find what I was looking for. I changed out the bars on my bike to fat bars and when I went to the track today the kill switch no longer works. I did have the switch hanging there swinging around because I pulled the top clamp to install a damper. Did something fall out? I searched my garage floor and didn't find anything. I took it off and put it back on a couple of times. Still no worky. Any help or ideas would be much appreciated.

Share this post


Link to post
Share on other sites

Trace Your Wires And Make Sure Every Thing Is Pluged In , Also Double Check That You Put It All Back Together Right . I Know Its Only Two Wires But Still.....

Share this post


Link to post
Share on other sites

ya either the black piece or when u were moven stuff around on ur bars u whacked the kill switch and the wires came loose inside the switch

Share this post


Link to post
Share on other sites

get a mechical/ele type fella to rewire a new after market kill switch, its simple, the kill switch will kill the engine when the two wires touch or complete the loop circuit, this is why you can just cut the kill switch off and the bike will still run as the two wires are (open) or not touching and closing the loop circuit

Share this post


Link to post
Share on other sites

Thats the piece thats missing. Thanks AgentSmith. I was going crazy trying to figure out what was missing.

Share this post


Link to post
Share on other sites

check the bike, when mine fell out it got stuck inbetween the radiator and shroud. took me about 2 hours to find it. drove me nuts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...