Jump to content
Sign in to follow this  

Help my 610 is dead

Recommended Posts

drove my 07 to work today and went home for lunch and tried to start it, it turned over and didnt start but now nothing works no light no nothing.

HELP PLEASE!!

Share this post


Link to post
Share on other sites

Leave the key on? If so jumper cables to car, check battery connections and fuses. Later George

Share this post


Link to post
Share on other sites

its eletrical im sure, it started at work. I drove home about 4 miles. ate lunch and went to start it back up, it turned like halfway over then ALL the lights on the dash and everything went out.

If the battery was dead it would still light up right.

its like a fuse blew but i looked in the book and didnt see anything about fuses.

Share this post


Link to post
Share on other sites

Will it bump start?

Check for loose wires at the battery or other obvious places. Kill switch, ignition switch if it has one etc.

Share this post


Link to post
Share on other sites

its got no electics at all, gonna try a jump box from work. but ive never seen a battery die so dead so quick.

Share this post


Link to post
Share on other sites
its got no electics at all, gonna try a jump box from work. but ive never seen a battery die so dead so quick.

Back in the '80s there was a rash of batteries that would break internally. You could be riding along and bam, nothing. A voltmeter across the terminals would show 0 volts but a hydrometer would show the cells were normal. I realize you have a sealed battery but check the voltage at the terminals. Good luck.

Share this post


Link to post
Share on other sites

Check your battery cables and fuses. It is not uncommon for the battery cable to loosen. If you have a short it will blow the fuse and you will have no juice. Check the easy stuff first.

Share this post


Link to post
Share on other sites

Most likely it is the stock battery most of us on ADV rider swaped out the stock battery from day 1 for a Yuasa YTZ-12S or Yuasa YTZ-14S (same size just more crank). The stock Varta is crap!👍

Share this post


Link to post
Share on other sites

I'd agree. Check the fuse first under the left side panel but a lot of riders have had the Varta battery go away with absolutely no warning.

Share this post


Link to post
Share on other sites

yep that varta is crap, bike is about a yr old and its shot.

skerd the hell out of me though the way it died.though i had some huge problem cause my fuses were ok. never really felt it dieing untill it just went completely dead. even tried charging it and nothing.

thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...