Jump to content
Sign in to follow this  

no mpg in the speedo

Recommended Posts

My speedo stopped showing MPH recently. The magnet is still in the rotor and the speedo's other functions seem to work. Any ideas what's causing the problem and how to fix?

Share this post


Link to post
Share on other sites

mine jumps around sometimes, like ill be cruising at 55 and itll jump to 78 or some s!%t. is there a fix for that or is that just nature of the beast.

sorry but its related topic and not important enough to start a thread, hope you dont mind.

Share this post


Link to post
Share on other sites

My 08 te 250 does the same thing. not only does the mph blank out the odo stops working too. so when I'm tracking dsistance on a dual sport ride I'm screwed.

Share this post


Link to post
Share on other sites
My speedo stopped showing MPH recently. The magnet is still in the rotor and the speedo's other functions seem to work. Any ideas what's causing the problem and how to fix?

It is either not getting the pulses (magnet, sensor, wires from sensor) or is not listening to the pulses (disconnect battery for a little while or replace the unit)...

I realize that people should buy products that work but the speedometer/computer is not one of Husqvarna's strong points. Maybe an aftermarket version or even a bicycle speedometer/odo connected to the same sensor/wires.

There have been instructions on how to re-build the speedometer/computer in the past using foam to keep the circuit boards together better and those have been successful but I cannot find those.

Share this post


Link to post
Share on other sites

i am a proud new owner of an 08 SM610 Husky and my speedo also stopped showing me the MPH within the first 150 miles... Thru this thread which my friend told me about I was able to fix the problem and saved me a trip to the dealership!

Question though: what is causing this and will this become a hassle? if so what is the long term fixes?

Share this post


Link to post
Share on other sites

husky speedometers are junk switch to afermarket no more connect or disconnect

Share this post


Link to post
Share on other sites

Behind the back left side panel is an electronics clump. At the top front of it is a 20 amp fuse. Pulling this will do the same as disconnecting the battery - and is much easier/faster.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×