kids atc70 will not run without coke on

engine just got rebuilt, new piston rings, carb, valves checked, timing checked, points new

anyways the engine will run strong without the choke only over 1/2 throttle.

the engine will not run up from idle unless the choke is on!

is this the idle or slow jet, i've tried different needle clip positions without much success

any thoughts on this problem?

pilot jet is plugged.

clean the carb throughly, the same problem persists!

the pilot jet is what? the screw with the spring right? if so when running that adjustment has no effect when turned.

when the engine is warm it idles but from 1/8 to 3/4 it will bog, seems like a lean bog cause it runs fine with the choke on, it also idles fine with the choke on

i dont understand this? its a new stock oem carb for this model

double checked the valves and timing and points gap all checked good, the only thing i cant check is the compression but its a new piston ring, seems to have great compression!

also, just cuaght my mind would changing the stock airfilter system to a k&n type, maybe less restrictive cause this?

Check the pilot jet by holding it to the light. It must be a clear crisp hole, blurry light will not work!

the pilot jet hole is clear, just to see if i needed a bigger pilot jet i ran a larger mig wire threw opening the hole, but it was to much, it now runs without choke on but is running very rich in the areas specified, i guess i going to buy some larger pilot jets, larger than stock that is!

the only thing that could of cause this is the less restrictive aftermarket air filter, i guess smaller engines can be very sensitive

i have the same problem let me know what jet size you end up with

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now