Jump to content
Sign in to follow this  

suttle Problems after being fixed any ideas?

Recommended Posts

i have a 2003 Yz250F the cam timing chain slipped making my timing off, i re timed my bike checked all the valves, checked the clearance everything was fine but the bike would only run with the choke on and wouldnt idle. i took the bike to my friend who owns a shop in ct because i had to have my forks re oil and sealed anyways, it turns out that there was a chunk of crud in the carb

but now it pops alot more than usual when i let off the throttle even with the clutch in, i let the bike idle and reved the engine slowly before cracking the throttle back and a six inch flame shot out the exhaust

i dont know if its a carb problem

anyone have an idea?

Share this post


Link to post
Share on other sites

Try a tank of 93 or 110 octane and see if that makes any difference, it does on mine. Flame shooting out the back is normal to lean. I would follow advice above and try cranking out the fuel screw 1/8 to 1/4 turn.

Share this post


Link to post
Share on other sites

usually i only run 93 through my bike but i gave it to him empty so i dont know what kind of gas he put in it

i guess tomorrow i'll back the screw out a little and see how it runs

i wish there was a way to throw flames minus the possible long term engine damage

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...