Jump to content
Sign in to follow this  

After cutting cylinder head and retarding timing, bike still pings..what to do?

Recommended Posts

I ride MX and I ride decently hard and use the clutch alot and rev the bike out of the bike. And I've got my head cut to .045 squish and the dome cut out to stock compression, and i've retarded the timing. And its still pinging, it doesn't seem as bad now that i retarted the timing.But its still doing it. And way to get rid of it besides running race gas?

I would run race gas but the only stuff I have locally is VP C-12 and that costs like $10 and that alittle too much for me, with how much I ride.

Share this post


Link to post
Share on other sites

if you still have detonation which you will with the shaved head you can try a lower heat plug. Also race gas always works.

Share this post


Link to post
Share on other sites

Are you certain its detonation?

My bike has no issues at .055 squish on 93 with jetting that would surprise some people. (I run typically a gallon c12 to 4 pump for safety though)

When you pull the plug, do you see and aluminum specs?

I just find it hard to believe it's an issue if your bowl was opened up....

Share this post


Link to post
Share on other sites

I imagine you on a yz 250, right?? If so, what pipe and silencer are you using? I found my fmf stuff to ping a little compared to stock. Also, if you have not tried the needle that was supplied from 07 on, you should. It was a little doggy for me at high altitude, but may be perfect for you.

Share this post


Link to post
Share on other sites
Are you certain its detonation?

My bike has no issues at .055 squish on 93 with jetting that would surprise some people. (I run typically a gallon c12 to 4 pump for safety though)

When you pull the plug, do you see and aluminum specs?

I just find it hard to believe it's an issue if your bowl was opened up....

I'm pretty sure its detonation. Because when I'm just cruising around or even every once in awhile I ride trails because there close by, the bike doesn't make a sound from the top end. But when I ride MX, I always hear a sound from the topend, which I'm 99% its pinging.

Nope, no aluminum specs on the plug.

Share this post


Link to post
Share on other sites
what throttle opening is the pinging occuring??

I hear it at every throttle position when I ride MX. It just this annoying sound from the topend. Maybe its just pipe noise, and with the more heat that MX probably causes it rattles more?

Share this post


Link to post
Share on other sites
I imagine you on a yz 250, right?? If so, what pipe and silencer are you using? I found my fmf stuff to ping a little compared to stock. Also, if you have not tried the needle that was supplied from 07 on, you should. It was a little doggy for me at high altitude, but may be perfect for you.

Ya, a YZ250.

I'm running stock silencer and pipe. Alright thanks, I'll get a N3EW, I have the N3EJ in my like right now.

Share this post


Link to post
Share on other sites

Maybe it's not pinging....just you hearing it.

Typically little specs in the electrode indicate detonation.

But you can always try one gallon c12 or similar to 4 gallons pump...if the sound goes away then, you know it's detonation.

Share this post


Link to post
Share on other sites

This thread is really good. Its now dumb question time. Are you running an aluminum glide plate /skid plate? As silly as that sounds, I noticed a bunch more odd noises from my bike if the aluminum plate is on. The sound travels right up to the rider.

Share this post


Link to post
Share on other sites

What is the head volume CC wise now?

If you see specs on the plug, your motor is toast already.

You have to pull head and llok at edges of piston and squish. If it looks like it's sandblasted a bit... you have detonation.

Share this post


Link to post
Share on other sites
This thread is really good. Its now dumb question time. Are you running an aluminum glide plate /skid plate? As silly as that sounds, I noticed a bunch more odd noises from my bike if the aluminum plate is on. The sound travels right up to the rider.

Nope no skid/glide plate.

Share this post


Link to post
Share on other sites
What is the head volume CC wise now?

If you see specs on the plug, your motor is toast already.

You have to pull head and llok at edges of piston and squish. If it looks like it's sandblasted a bit... you have detonation.

I don't know what the volume CC is right now, I think its around stock. I did try a head with the dome opened up and stock squish and it still pinged.

The edges of the head and piston look fine. Is it possible to ping, without causing the head/piston to look like it was sandblasted?

Share this post


Link to post
Share on other sites

Actually it did it again today. But I think the problem is I just hate engine noise and I'm like paranoid about it. I think its normal, but I'm just paying attention to it more now. Also I'm not really sure if the noise is coming from the head.

Share this post


Link to post
Share on other sites

I have a question...If my piston and head don't show pits or anything on the edge. but i still hear my yz250 ping pretty badly, should i worry about it.

i've cut my head to .045 squish and retarted the timing alot, and am running kinda rich jetting(atleast the needle and main) just to silent it alittle(50 pilot, N3EJ 3 clip, 180 main). but still after like 10 minutes of hard mx, it pings pretty bad, while on gas and on deceleration.

Share this post


Link to post
Share on other sites
I have a question...If my piston and head don't show pits or anything on the edge. but i still hear my yz250 ping pretty badly, should i worry about it.

i've cut my head to .045 squish and retarted the timing alot, and am running kinda rich jetting(atleast the needle and main) just to silent it alittle(50 pilot, N3EJ 3 clip, 180 main). but still after like 10 minutes of hard mx, it pings pretty bad, while on gas and on deceleration.

I don't think you bike is pinging, I think you just paranoid about engine noise.

On my YZ it would ping at like 1/4 throttle and 1/2 throttle. It has never pinged on deceleration, and don't forget that all two strokes are gonna make some noises. Detenation sounds like someone is throwing a hand full of pebbles at your cylinder.

Share this post


Link to post
Share on other sites

What is your cranking compression? Anything under 175 lbs and normally you will be OK on pump gas(92).

I aree it wont detonate on decel. Have you checked piston clearance??

Share this post


Link to post
Share on other sites

Ive never heard of pinging across a whole throttle range. When i had problems it was only 1/8-1/4 range. And Two-Six is right, it does sound like a bunch of rocks or pebbles hitting your cylinder. Or like your chain is super loose and hitting stuff.

Share this post


Link to post
Share on other sites

Are you sure you lowered the timing and not advanced it by accident?

I didnt think many dirt bikers even touch their timing..

Share this post


Link to post
Share on other sites

It is nearly imposssible to detonate on decel, it will only happen with a load. If the plug looks good also I would almost bet it is something else.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×