Jump to content
Sign in to follow this  

KX100 won't idle...tried everything?!?

Recommended Posts

Just put a new crank, seals, bearings and top end in an older KX100 but it will not idle now. Carb is clean, power valve is clean, gas is fresh. Checked for air leaks, couldn't find any. Idle screw adjusted all the way in but the thing just dies when you let off the gas.

Any suggestions?

Share this post


Link to post
Share on other sites
Just put a new crank, seals, bearings and top end in an older KX100 but it will not idle now. Carb is clean, power valve is clean, gas is fresh. Checked for air leaks, couldn't find any. Idle screw adjusted all the way in but the thing just dies when you let off the gas.

Any suggestions?

clogged piolt jet? float height

Share this post


Link to post
Share on other sites

My money's on a too-rich pilot jet that was being compensated for by the lean condition that the leaking crank seals were causing. Now that the crank seals no longer leak, the pilot is way too rich.

Share this post


Link to post
Share on other sites
My money's on a too-rich pilot jet that was being compensated for by the lean condition that the leaking crank seals were causing. Now that the crank seals no longer leak, the pilot is way too rich.

Can't argue that. :lol:

Share this post


Link to post
Share on other sites

I think my KX100 is losing it's balls (in the governor). I took it apart and the thing is stuck open. It looks like the balls were about to fall out but it didn't open quite enough to let them. I was able to get it to close on the bench but it just sticks open if I squeeze with two pairs of channel locks. Do I just press off the gear to inspect everything? The manual just says to replace damaged parts but doesnt say how to take the thing apart.?? Any help would be great! Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×