Hot start plunger

My hot start is frozen up on my 08 450. I'm a little surprised it would do this on a bike that's so new, but it has. Anyhow, I've been trying like crazy to get it unfrozen but I've had no luck, any suggestions?

Send user "mxkid1p" an email, as he just addressed this issue on his 2008 kx450f. I will try to remember to send him an email tomorrow as well.

I'm paranoid about mine seizing up. So I keep water away from the top of that cable. Problem on all FCR carbs if water gets down the cable. Just curious, you ride a lot in the wet and/or pressure wash near the controls?

I'm paranoid about mine seizing up. So I keep water away from the top of that cable. Problem on all FCR carbs if water gets down the cable. Just curious, you ride a lot in the wet and/or pressure wash near the controls?

Yes I use a pressure washer but I don't ride in wet condtitions all that often, next to never actually.

Mine locked up with in like 4 months. It really wasn't that hard for me to fix, here is what I did...

I purchased the plunger kit from the dealer #: 16016-0017. I destroyed mine getting it out. I took off the cable at the carb. Used a pair of needle nose pliers to get the old plunger out. Then I used some carb cleaner and a little piece of like 600 or 400 grit sand paper to clean up the corrosion. I installed the new one with a little water proof grease around the oring and I was good to go. I haven't had a problem since. I hope that helps!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now