alta vista ranch

i got a question about desert racing

i here thers is racing out in cal city how do i find out and sing up :thumbsup:

cool thanks

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By TheVolta
      New bike is confirmed, your welcome. 

    • By DanielX450
      Hey guys I could really use some help. I bought a 2005 CRF 450x that has an aftermarket air filter, full FMF exhaust system (pipe and header), removed backfire screen, and removed air snorkel. Bike idles and starts just fine, but when I hold the throttle anywhere from barely at all to about 1/2 it bogs, wants to die, and backfires. Seems like lean running conditions to me because if i leave the choke on the problem mostly goes away. Additionally, if i move the air screw out almost all the way (to the point where it could vibrate off), it seems to clean up a little bit. I am trying to determine whether bigger jet(s) would fix it or if its something else. My dad thought it might be the float level, but I'm really not sure. Thanks in advance for your help!
    • By pro dirt
      hi, I'm buying a crf450x and this is the first 450x I'm gonna own but i was a bit confused on one of the pictures. i checked on other crf450x pictures and could not find this on any of the others. There is a gap right below the air filter and above the swingarm and I was wondering if it was normal. 
       
      Thanks!!!

    • By David Rediger
      I have a 05 CRF450X that was just rebuilt that is not starting via its electric start. I can start it with the kick starter as well as a rolling start down a hill though. Once started it seems to run just fine. I have it at a bike shop right now and they are stumped as well. So far I know the battery has been tested/replaced, the carb has been cleaned, jetting is good, and they have also tested the starter motor and things all look okay. Any ideas where to look next?