Jump to content
Sign in to follow this  

XR650r carb question

Recommended Posts

I ride a 2000 XR650r. It start right up cold or hot as long as I shut down the petcock before killing the engine. Starting after a stall is a different story. Its no big deal to do this but I want to fix it anyway. Any suggestions?

Share this post


Link to post
Share on other sites
I ride a 2000 XR650r. It start right up cold or hot as long as I shut down the gascock before killing the engine. Starting after a stall is a different story. Its no big deal to do this but I want to fix it anyway. Any suggestions? Im thinking it may be float position?

Gas cock? Is that the same as the petcock? I would guess it may have something to do with the float position?

Share this post


Link to post
Share on other sites
I ride a 2000 XR650r. It start right up cold or hot as long as I shut down the petcock before killing the engine. Starting after a stall is a different story. Its no big deal to do this but I want to fix it anyway. Any suggestions?

You might have a float needle sticking.

Has it sat for any length of time? May need to O/H the carb.

BTW, welcome to TT.:busted:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×