Jump to content
Sign in to follow this  

Help Can I fix this

Recommended Posts

No

This happend last spring I got the bike from a dealership and it did this the next day i just thought I would share.

The dealership had to buy me a new motor cause they put in a rod and didnt do the install correct

DSC03846.JPG

DSC03855.JPG

DSC03860.JPG

Share this post


Link to post
Share on other sites

wow thats impressive. Good thing you didnt get hit in he leg by shrapnul. A little jbweld and you should be good to go:busted:

Share this post


Link to post
Share on other sites
Yeah, a little JB Weld and an oil change and she will be good to go.
wow thats impressive. Good thing you didnt get hit in he leg by shrapnul. A little jbweld and you should be good to go:busted:

jb weld would do a good job I could mold the cylinder wall back in that way:thinking: :moon::busted:

Share this post


Link to post
Share on other sites
no wrist pin clip from what I was told

No problem. I'll simply use this here paper clip, wrap it around my trusty pry bar. I got your clip right here!

Must of gotten to that point on a Friday night at closing, finished up on Monday.....

Share this post


Link to post
Share on other sites

My first thought was a missing circlip:banana: All these years of blowing stuff up is finally paying off:smirk:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×