02 WR426 Stalling when pulling in the clutch, Weird

I'm working on a bike that's not been run for a couple of years. I've gone through the bike, carb clean, valves, plug, new fluids etc.

It's cold here (40deg F during the day), I never can get it to start on the first kick, but 99% on the 2nd one(so I guess it's not my worst problem) :thumbsup: . I let the bike run in Neutral for 20-30 sec with the choke on, then push it off. Bike idles nice, and throttle response is very crisp and WR like.

When I pull in the clutch lever, it stalls. It's almost like it's an ignition cutoff switch. If I rev up the bike to about 50%, I can get it into gear and get it moving, but if I let the idle go down, and pull in the clutch, it will DIE.

For giggles, I tried this with the kick stand up and down, I have no wires there, but checked to see if the bike had a stand cutoff.

I've checked to see if the clutch cable moves any wires, or moves any ignition wires, everything looks OK. I haven't pulled off any covers to see if I'm rubbing a wire anywhere. Also the clutch doesn't have any wires connected to it at the perch, so I don't think it's any safety device.

I haven't run any tests yet with an ohm meter to check the ignition system yet, but I scratching my head as to why pulling in the clutch in stalls the bike. Bike has a Baja kit, so I'll start trouble shooting there at the light switch, and it's next to the clutch perch, hmmm(thinking out loud).

The bike sure likes to wheelie, I can't wait to get some serious time with it in the dirt.


the only thing i can think of is it is pulling the compression release as well somehow.

I agree with True_2. I had the same problem. It happened twice, once it was when I pulled in the clutch, the other was when I turned right. Both times it was pulling the decomp lever. I just moved it on the perch and it cleared it up.

If the bike has been sitting for a while, the clutch plates may be stuck together so the clutch doesn't release.

I should of posted this a while back, I found the problem, almost an embarrassing problem.

I have my controls by the clutch lever, headlight, signals, horn, and KILLSWITCH. the killswitch lever in on top of the control, when I pulled in the clutch, it hit the lever.

Slight rotation of the control solved my troubles.:p

I did do an adjustment to the compression system per recommendations above(can't hurt), it was out of spec. Then I saw the kill switch being hit by the clutch lever.

You guys ROCK


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now