Was running fine and now no compression / no start

Had her wide open on a 20 minute ride, was slowing down coming into a corner and it stalled on me. Would not restart and I noticed that it was dripping oil pretty heavily (more than usual) out of the crankcase breather hose. I thought that I had possibly fouled the plug but that checked out fine, then I noticed a loss of compression-it kicks right through without the release. I'm stumped.

Could be a stuck exhaust valve...

Surely some of you have experienced this problem before? How do you check for a stuck exhaust valve and can it be dislodged or just replaced?

My riding buddy experienced the same thing last weekend at Gorman. On a older DR350. He lost compression. We were able to push start the bike.

One thing I did notice was that his decompression lever wasn't working. After we push started the bike it ran ok. Also the decompression lever started to operate properly. You may want to check your decompression lever out. Maybe it is stuck.

If you have a manual you may also want to check your valve clearance.

First things first. Make sure your decomp cable or lever didn't bind. If it is working normally, you will hear a click just before it engages and see free play where the cable connects to the engine.

If not that, several people have lost compression mysteriously and have had it reappear after starting. By lost, I mean push it through easily by hand. In every case, I have seen, it was lost while sitting and came back after starting. To start it, give it 1/16th throttle, kick it, then 2/16ths, kick it, and so on. Eventually, you open it up enough to get enough air in there for it to fire up. You can shut it down immediately and the compression will be back. I have had this twice on my bike and seen it twice on two different bikes and the same each time. The second time it happened on my bike, I pulled the head (and wrote it up on TT) cleaned the valves (coral like deposit on back of exhaust valves) and put it together thinking I had fixed it. Still no compression, but it had compression after starting once.

Recently I lost compression after riding while washing my bike at the track. I used the 'add throttle til it starts' trick and then cut it off. I still didn't have compression. I started it several times and ran it for maybe 10 minutes total at the track w/o compression. I got home, still no compression, started a few times, still none. Tore it down, saw no problems other than intakes a little tight (not enough for this). While in there, put in new piston, rings, wrist pin, clips, lapped valves, reshimmed and had perfect compression when I put it back together. Oh yeah, I did the solvent leak test before I pulled the valves with contact cleaner and it held fine. I cleaned up the head and pushed the valves a few times and then tried it again and a couple leaked. I assume I got trash in the face while cleaning.

I have no idea why it lost compression, why it wouldn't come back, or what I did that convinced it. It wasn't the rings or shims because they don't just go out all of a sudden like that. I think.

Start it using the 'increasing throttle' method, unless binding, clacking, etc., and it will almost surely have compression after that.

Good luck,


This happened on my bike 2x in past yr, once nov in winter second time march now it's july and has not happened a third time yet, some posts suspect decomp lever, I now spray a little wd-40 at the return spring where the bolt that opens exhaust valve goes into valve cover in case it sticks enough to hold valve slightly open and the motor pushes it closed once started. When I checked clearance the exhaust were in spec but on the loose end, is it possible when valves get looser the sping would have trouble closing them completely allowing enough air bypass the kicker just spins the piston then when it starts first firing pf plug the valve manages to stay closed enough to keep the motor running.

Thanks all, I will try your suggestions tonight. It has happened to me once before when I ran it wide open to reach the top of Sand Mtn. at the Little Sahara Dunes. Right at the top when I let off on the throttle it died. Wouldn't restart with kicking so I turned and coasted down the monster hill and bump started it at the bottom. Ran fine after that until now. Maybe I can jump it again but I really don't want this to become a routine occurence!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now