Installing IMS 2.6

When installing the IMS tank I knew I was going to have to make a bracket for the back of the tank but I wasn't aware of how poorly the stock radiator shrouds match up to the tank. I had to use nylon spacers to make it look reasonable. I don't have the horn on anymore but I'm thinking there would be an issue with that as well if it was still there. It would have been nice to have a better fit but this isn't a beauty contest and I do like the idea of a plastic tank off road. I haven't had a chance to ride it yet (snow on the ground this morning) but I do like how low it is at the front of the seat now.

I found these nylon spacers at Home Depot. 1" OD, 3/8" ID, 3/8" thick. Inside of those I put some 3/8" OD, .197" ID, .5" thick spacers that I cut down and drilled out. I know it's over kill but I put the spacers in yellow Rit dye overnight to get a better color match. I bent the bracket out of some sheet metal I had laying around.

a0bdjt.jpg

Left side

289ctfo.jpg

Right side. I had to cut the top spacer down to 1/4" thick because 3/8" made it stand out too far.

os4ryq.jpg

Seat on

23sj24n.jpg

And one so my other "baby" doesn't get jealous.

eipbwo.jpg

you just bolt the shrouds on as normal they will relax and form to the tank.

you just bolt the shrouds on as normal they will relax and form to the tank.

LOL, as usual I was way over thinking the situation.

how did you get it in yellow? thought they only came in clear.

No , 2.6 tanks are special order , so when you order one you can choose the color ! Someday i'll get one...!

you can order them in yellow, green, or natural

I just ordered mine in natural thru justgastanks.com and it drop shipped to my door in about a week

you just bolt the shrouds on as normal they will relax and form to the tank.

Yea mine did just that> didnt add spacers,just one to the black oil breather box to space it.

Oh and I got mine in black, I also modified the bracket and kept the horn in same location .

Pics in garage.:lol:

Looks good, npm. :lol:

I've got a black IMS 2.6, too.

Their website doesn't list all of the colors they offer it in.

When you call, just ask.

I had a IMS 3.2 but the bars would hit it when turned all the way left. DO you have this issue with the 2.6? Other than that I loved the tank but sold it.

I dont have any problems with my 2.6, as far as the bars or forks hitting. I relocated the horn to the front motor mount and used a smaller Baja Designs horn. I removed the fan and took out the thermostat. I may try to sneak a computer fan in, Ive overheated it in some extreme conditions.

Heres a pick of the horn. I had to extend the harness to reach it.

KX500MFR024.jpg

I dont have any problems with my 2.6, as far as the bars or forks hitting. I relocated the horn to the front motor mount and used a smaller Baja Designs horn. I removed the fan and took out the thermostat. I may try to sneak a computer fan in, Ive overheated it in some extreme conditions.

Heres a pick of the horn. I had to extend the harness to reach it.

KX500MFR024.jpg

I dont use a horn on mine anyway it stopped working so I just took it off. As far as the fan I left it. Did you need to remove the fan or chose to?

will not fit with the fan.

will not fit with the fan.

Im guessing this is because the IMS carries the fuel lower to flatten out the seat some?

lowers the front of the seat 3-4 inches.

For what its worth for ya. IMS 2.6G , computer fans (soon will be more of them), horn re-located, etc. I now (finally) have some graphics on the tank but not in these pics. The fitment is as Mr. Sisneros has said.

DSC03692-1.jpg

DSC03684.jpg

DSC03685-1.jpg

Thanks, I have the Trail tech so I can monitor engine temps.

No fan and no horn on mine. I absolutely love how the seat is so much lower in the front. I can slide way up and still touch the ground giving me a lot more confidence when I'm on the tight stuff.

I just recently read a thread about how the E tank mounts with brackets to the front of the tank and realized I possibly didn't have the tank mounted securely enough. After running this tank for a year with out the front mounts and just the radiator scoops to hold the front down I finally ordered the mounts. When I went to install them there is only one bracket on the right side of the S frame. It originally had the horn attached there but that is long gone. Is it ok to run with just the one front mount or even leaving the front mount off altogether?

yes,thats how it works.its just the one front mount.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now