'86 Tt225

Anyone have any ideas for what could be causing my problem? I just cleaned (boiled and used carb cleaner and ran small wire through all the holes) the carb again, tried some various main jets and still no better. It starts great and idles great. When the throttle is at 0% and I pop it to 1/4, or even 1/2, it revs pretty well, but when I pop it from 0% to1/2-full..it bogs and will cut off unless I let off the throttle. I can't tell you how annoying this issue is!!! I just want to have fun on it again....it runs, but has no powerband so I just basically putter around on it while my 8 year old son whizzes by me on his TT110..lol.

What was wrong before you cleaned the carb did it sit for a long tome ? When did the problem start. You can try and raise the needle . What kind of air cleaner are you using. More information would help to answer your questions.

Thanks Mike..here you go! The bike did not sit for a long time. I've had it for a couple of years now and it has always started and idled well....just has always had the bogging/no powerband issue. I cleaned the carb just because I was troubleshooting and wanted to see if it would help. It has a new sprak plug and the gap has been checked. It uses an OEM air filter that is new/clean and the airbox has the snorkel removed. I checked the valves and compression last summer and they were both fine...the bike will start with 1 kick. The only thing I can tell you may offer a hint is that last summer I went over a jump and she "woke up". Powerband was there..throttle response was there, etc...it ran like the bike should. It reverted back to slow/boggy bike so I decided to go over a jump again....and it worked like a charm..bake to fine running bike again. It has been running poorly again for a few months now and no matter how hard of a jolt I give it...it doesn't help. When it's idling I can pop the throttle to about 1/2 and it's pretty responsive...any more than 1/2 from 0% and she will bog and cut out if I do not let off. I hope this helps.....I'm not a mechanic, but I am mechanically inclined and I love getting things working properly again. This issue just is not making sense to me, but there has to be an answer, right?

make sure you have some choke plunger freeplay

The choke seems to work as it should...moves freely, but has enough tension to not move on its own.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now