My 08.5 wont start

I just installed an FMF Mega Bomb and 4.1 exhaust on my bike and installed the Power Commander 3. I did as the instructions said and now my bike wont start. I unhooked the power commander and hooked back the stock connections and still wouldnt start. I checked the plug and it was getting fire. Some how its not getting fuel. Anyone have any ideas? If I take it to a dealer can they hook it up to a computer and find out whats up? By the way, this is my 1st fuel injected bike and everything has been great until now.

I just installed an FMF Mega Bomb and 4.1 exhaust on my bike and installed the Power Commander 3. I did as the instructions said and now my bike wont start. I unhooked the power commander and hooked back the stock connections and still wouldnt start. I checked the plug and it was getting fire. Some how its not getting fuel. Anyone have any ideas? If I take it to a dealer can they hook it up to a computer and find out whats up? By the way, this is my 1st fuel injected bike and everything has been great until now.

I'm sure you already know this but, something is hooked up wrong or is disconnected. Is there gas in the tank and is the fuel pump properly plugged back in?

I'm sure you already know this but, something is hooked up wrong or is disconnected. Is there gas in the tank and is the fuel pump properly plugged back in?

Ya check for the normal stuff.Just so you know if these things get way low on fuel they will not run.go back and check all conections and check and make sure there is no packing pluging the pipe.

Did you down load the wright program to the pcIII?

hmmm...clogged injector possibly?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now