Jump to content
Sign in to follow this  

My 08.5 wont start

Recommended Posts

I just installed an FMF Mega Bomb and 4.1 exhaust on my bike and installed the Power Commander 3. I did as the instructions said and now my bike wont start. I unhooked the power commander and hooked back the stock connections and still wouldnt start. I checked the plug and it was getting fire. Some how its not getting fuel. Anyone have any ideas? If I take it to a dealer can they hook it up to a computer and find out whats up? By the way, this is my 1st fuel injected bike and everything has been great until now.

Share this post


Link to post
Share on other sites
I just installed an FMF Mega Bomb and 4.1 exhaust on my bike and installed the Power Commander 3. I did as the instructions said and now my bike wont start. I unhooked the power commander and hooked back the stock connections and still wouldnt start. I checked the plug and it was getting fire. Some how its not getting fuel. Anyone have any ideas? If I take it to a dealer can they hook it up to a computer and find out whats up? By the way, this is my 1st fuel injected bike and everything has been great until now.

I'm sure you already know this but, something is hooked up wrong or is disconnected. Is there gas in the tank and is the fuel pump properly plugged back in?

Share this post


Link to post
Share on other sites
I'm sure you already know this but, something is hooked up wrong or is disconnected. Is there gas in the tank and is the fuel pump properly plugged back in?

Ya check for the normal stuff.Just so you know if these things get way low on fuel they will not run.go back and check all conections and check and make sure there is no packing pluging the pipe.

Did you down load the wright program to the pcIII?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×