Jump to content
Sign in to follow this  

XT200 starting and running problems

Recommended Posts

So I've got an 82 xt200 yamaha and it's been giving me some strange problems. I've searched but can't readily find info specific to my problem. I can get it to start on the first kick but it immediately dies with any throttle until I've done this about 10 times. After starting it a few times and it dying it will start and run ok but there is a miss every once in a while at idle. What's more is when I take it out on the street it's like at a certain point in the throttle it just dies completely and is a beast to get started again without letting it sit. Suggestions please!

Share this post


Link to post
Share on other sites

I owned one of those back in the day.

Have you checked the condition of the inside of the carburetor?

How about the airbox and air filter?

Share this post


Link to post
Share on other sites

Yeah, I just had it apart and tore down a few days ago. Internals are new and same spec as old internals. Air filter is new although it wouldn't hurt taking it off and checking it out. I'm thinking float level or air/fuel screw adjustment but I don't know. I just thought i'd check for suggestions before I resorted to guessing and checking because that carb sucks to take off and put on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×