Jump to content
Sign in to follow this  

Works Perfornance Shock: Fade?

Recommended Posts

Any of you Works Performance owners out there experience any appreciable fade over the course of a ride or weekend? The body of that shock is awfully small given the large spring rates used... Seems to me that the small amount of oil is working pretty hard.

Owners only, please. Experience counts. Speculation stinks, I can do that (and do!) on my own! :p

-Tom

Share this post


Link to post
Share on other sites

I haven't noticed a change over the course of a ride weekend. If there was one then I would definitely notice.

Share this post


Link to post
Share on other sites

Mine is working great. I think even if it does fade some it will still be better than the pogo shock put on by Honda.

Share this post


Link to post
Share on other sites

Thanks for the responses, guys. I didn't expect EVERYONE to be completely satisfied.

Mine is working great. I think even if it does fade some it will still be better than the pogo shock put on by Honda.

Amen, Yance.

-T

Share this post


Link to post
Share on other sites

Usually there are slight changes during the first hundred miles or so during break in. After your first oil change there will less change with use.

Dwight

Share this post


Link to post
Share on other sites

I have one on a '2005 CRF230, it's been working for 2 years now, I've not been able to detect any ride deterioration. :p

.. as compared to my totally "dead" shock desperately in need of a recharge/rebuild on my 1983 XR200R, it's like a pogo stick!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×