Jump to content
Sign in to follow this  

Yet Another Mcct Question

Recommended Posts

Well I finally quit procrastinating and installed my Thumper Talk MCCT today on my 2001 Suzuki DRZ S. Install went as advertised. I'm pretty sure I heard the Coke Can/ marble noise and all that, dialed in the MCCT so the Coke Can/ marble noise went away (just) ect ect.

My bike seems to run like a champ, but I used to have some noticeable popping on deceleration using engine braking. Post MCCT install, the vast majority of the popping on deceleration is GONE. I am not complaining, just wondering if I might have inadvertently eliminated the deceleration popping noise by over or under adjusting the MCCT???

After removing the ACCT, I reset the plunger and checked what the spring pressure of the ACCT felt like on the plunger (using my hands). If I were to guess, I would THINK the tension I tightened the plunger on the MCCT (using fingers only) feels less then what the spring pressure the ACCT was delivering when installed.

SO the MCCT is in , the install went fine and the bike actually seems to run a bit snappier and the popping noise she used to make on deceleration is gone. My ONLY worry is, do you guys (Eddie)think these seeming improvements in engine performance are normal or do you think I have tightened up the MCCT to much/little and I am now putting new stress or too little tension on the cam chain??

In summary my bike SEEMs to run better post MCCT install , is this possible or do you experts think I puked it up???

Thanks in advance..........

Share this post


Link to post
Share on other sites

It sounds like everything is fine, but i have no idea why it would stop popping on decel. :ride::moon: Did you make any other changes to the bike?

Mike :p:moon:

Share this post


Link to post
Share on other sites
It sounds like everything is fine, but i have no idea why it would stop popping on decel. :ride::moon: Did you make any other changes to the bike?

Mike :p:moon:

Negative only change was Mcct......

Share this post


Link to post
Share on other sites

Check your intake cam ,might have skipped a tooth during dialing in the mcct.

Share this post


Link to post
Share on other sites
Check your intake cam ,might have skipped a tooth during dialing in the mcct.

Bike was at TDC for install........

Share this post


Link to post
Share on other sites

How old is the gas in your tank?

Might have something to do with it as far as the popping difference.

I rode mine for the first time since December 1st just about 10 days ago, and it was also the first ride with my MCCT.

The bike seemed to rip even better than I'd remembered, but I realize it could be my euphoria of actually riding it again (for the first time in 3 months) having a lot to do with it.

I also had just installed a fresh and brandy-new Ready Filter oiled foam air filter, so that could have helped.

My bike seemed to pop on decel as usual, which is lightly.

Share this post


Link to post
Share on other sites
Bike was at TDC for install........

Yupp ,but I'll guess it was running when you dialled it in ...

Share this post


Link to post
Share on other sites

I noticed no difference in performance when I changed mine. YZetc, I get the same feeling when I don't ride my bike for a couple of weeks. When I do hop on the bike, it always feels stronger than when I had last ridden it. Its weird, but a good feeling, but perception is not reality.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×