Jump to content
Sign in to follow this  

starting help needed

Recommended Posts

hi all am new to drzs have got a drz400s that was running ok but not charging the battery got someone to check it for me and he said the alternator needed re-winding i got this done but now the bike will not start took it to a freind who works at a bike garage it has got a spark but he could only get it to backfire a couple of times he has checked the electrics and said all the multimeter readings checked out ok the kill switch has been checked and the stand switch and the clutch switch have already been removed by the previous owner also he checked the valve timming and valve clearance which he said was ok fuel is also ok he is pulling his hair out anyone got any ideas

Share this post


Link to post
Share on other sites

Have your mechanic test the starter relay (Suzuki calls the part the "starter solenoid"). Mine went bad recently as well. After I installed a new one and the new battery (my second new battery in two months), my bike fired up PDQ.

The starter relay is the black square plastic thingee on the right side of the frame, below the right rear panel and above the exhaust pipe. Two metal screws attach it to the frame and to the (I think) positive lead to the battery. It's also a bit of a pain to install.

Share this post


Link to post
Share on other sites

It sounds like the motor cranks OK so the starter relay is not the problem in this case.

It is likely it is the ignition pick-up. There is a coil in the stator and a coil outside of the stator. The one outside can be installed backwards. Either of the coils could be bad which you can not determine with a simple multimeter test.

Check the installation of the external pick-up. If that is OK then you will have to try a different known good stator to see if that corrects the problem. Perhaps in England rewinding stators is a common practice. Here in the US, it is not and not many places would know how to do it correctly. I suspect your problem is related to the stator rewind process.

Share this post


Link to post
Share on other sites

thanks for the replies yes the bike turns over fine just will not fire up have checked the position of the stator coil and that all seems ok cheers courty

Share this post


Link to post
Share on other sites

the guy working on my bike found a local garage that had a drz in for a service he swapped the cdi unit from mine and the other bike would not start so looks like the cdi has had it have bought a second hand one so hopefully this will cure it

thanks courty

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×