Jump to content
Sign in to follow this  

Head Gasket Help Please

Recommended Posts

This is my first post here, and I could really use some help.

My 04 yz250 is getting coolant in the cylinder. It was running fine this last weekend when it burnt up a piston (i think due to running it to lean). I ordered a new top end kit for it and my CR250, I have never don a head gasket on a Yamaha before but have rebuilt many 2 stokes.

The head gasket there is a set of o-rings. I am pretty sure the inner is not sealing. I keep getting coolant in the cylinder every time I run it. And not just a little.

I have replaced the gasket 3 times the last time I even used some gasket maker to keep it in place/get a better seal and still coolant in the cylinder. Any input would be awesome. :p

Share this post


Link to post
Share on other sites

check it for flatness...and make sure its not grooved or chipped anywhere.

Base gasket is ok too?

I would have to say find a straight edge (like a machinists straigth edge) and check them, head and cylinder...and if it's not that...then maybe a cracked cylinder (unlikely)

Share this post


Link to post
Share on other sites

Thanks for the quick reply,

The cylinder is definitely not cracked. I have wet sanded the mating surfaces on the head and cylinder with 1000 grit and they both look ok.

Could a base gasket cause coolant in the cylinder? I will have to pull it and check if so.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×