Jump to content
Sign in to follow this  

excessive smoke

Recommended Posts

Well I just put a new topend in my 250xc and after breaking it in, and then riding a little harder it now smokes alot, also the power does not seem to be there, It has more then before the top end, just not in the same way. any help would be apprecitated.

Share this post


Link to post
Share on other sites

No i did not remove the power valve, but cleaned all around it and made sure, it would open correctly.

Share this post


Link to post
Share on other sites
did you remove or clean the power valve?

I probably need to check my power valve too. My bike smokes A LOT, and burns gas like a big block Chevy. My riding buddies who were following me last week said that they could smell gas in my exhaust. I have the bike jetted very lean compared to what the manual calls out and that has reduced the spooge some but it still sputters from 1/4 to 1/2 throttle. I have a clean air filter. I checked the reeds and they are fine. I repacked the silencer. Put a new spark plug in. Cleaned out the carb. I have not checked the stator coil or power valve though.

What do you think?

Share this post


Link to post
Share on other sites
I probably need to check my power valve too. My bike smokes A LOT, and burns gas like a big block Chevy. My riding buddies who were following me last week said that they could smell gas in my exhaust. I have the bike jetted very lean compared to what the manual calls out and that has reduced the spooge some but it still sputters from 1/4 to 1/2 throttle. I have a clean air filter. I checked the reeds and they are fine. I repacked the silencer. Put a new spark plug in. Cleaned out the carb. I have not checked the stator coil or power valve though.

What do you think?

That sound kind of like what ive got, but it does not smoke a whole lot when I am on it.

Share this post


Link to post
Share on other sites

first thing i have to say is look into 4 strokes. and the second thing, i had the same problem with my 04' rm125. new top end and new jetting and still smoke. it turned out to be a crank seal.

Share this post


Link to post
Share on other sites

I agree just go get a four stroke. I will take your two stroke for you. If you are having troubles with a smoker just wait till you drop a valve, break a timing chain or something terrible like that. I would make sure your pv timing is on and pull your pv out and polish er up.

Share this post


Link to post
Share on other sites

i am probably dang stupid, but i have never seen a picture of what this PV vlave looks like or where it is even located... i dont have a manual and nobody ever posts pictures to explain what they talk about...

what does the pv spring look like, where the hell is this PV area, and how do i get to it...

Share this post


Link to post
Share on other sites

Id like to thank my roomate from wrting the 4 stroke comment (on my account), even though his laps on his 4st take about a minute longer then my 2st

Share this post


Link to post
Share on other sites
Id like to thank my roomate from wrting the 4 stroke comment (on my account), even though his laps on his 4st take about a minute longer then my 2st

Thats pretty funny, get on his account and go thumper bashing. While your at it give him some bad gas.

As far the PV question; Pull your exhaust pipe off and look into the motor. there is your pv. I would get a manual, it will be worth it. I cant tell you how to take it out.

Share this post


Link to post
Share on other sites
I probably need to check my power valve too. My bike smokes A LOT, and burns gas like a big block Chevy. My riding buddies who were following me last week said that they could smell gas in my exhaust. I have the bike jetted very lean compared to what the manual calls out and that has reduced the spooge some but it still sputters from 1/4 to 1/2 throttle. I have a clean air filter. I checked the reeds and they are fine. I repacked the silencer. Put a new spark plug in. Cleaned out the carb. I have not checked the stator coil or power valve though.

What do you think?

The stutter in your 2000 KTM 300 is likely due to the needle and PJ as well as a large squish band.

Jetting: Depending on your slide, I would go with a DDK or CEK straight taper needle from Sudco and a 40-42 PJ and 2 sizes up on the main, IF you are running a stock NOZ needle now.

Squish: Check it using the solder technique (search) If >0.05", get the head cut by Munn racin in TX or Jbone motor works in CT and tell them it is to help with off-idle jetting performance. tell them what octane gas you run (pump or race).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×