Jump to content
Sign in to follow this  

04 RM 85 no power with throttle open

Recommended Posts

Just got 04 RM 85 bike starts 1 kick runs great on a stand power valves open. Bike had top end rebuilt 1 1/2 years ago sat for 1 year. I cleaned carb drained gas flushed put new in. The problem is when you ride up to 1/4 twist runs great past that it feels like it is hitting rev limiter not bogging just hit and miss all the way to WOT.

I have checked floats, reeds cleaned carb,and air filter. Changed jetting it makes vary little difference. I have never had a problem like this before I have adjusted carbs don't think that is my problem.

All mods I see are vforce reeds, PR2 cool head, stock pipe, carb jetting primary 50 main 128 needle 24NAAH.

Thanks for any help

Share this post


Link to post
Share on other sites

Sorry forgot to put that in changed and checked plug showes the carb is good.

Share this post


Link to post
Share on other sites

Sounds like you are missing a powerband :p

It seems like a throttle valve problem. Take the throttle needle out of the carb and try raise or lower the clip and see what happens. This is responsible for the 1/4 - 3/4 range.

I had a similar problem with my RMX, fine 1/4, ran like crap to 3/4 and then went like a madman to 4/4. Ended up being to lean.

Share this post


Link to post
Share on other sites

Found problem bolt missing off bottom of coil to ground wire to coil. Put bolt in runs great from idle to WOT.

Thanks for the help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×