Jump to content
Sign in to follow this  

505-xc oil all over.

Recommended Posts

Had the valves checked mechanic saidn they were a little loose, Also added the 8oz flywheel.

took the bike for a short ride this weekend notice oil pumping from the right side of the motor from the weep hole at the top of the the valve cover.

Any input on what went wrong ??

Share this post


Link to post
Share on other sites

I was really hoping for some input as to what would cazuse the bike to push oil out of the vent hose at the top of the valve cover ??

Share this post


Link to post
Share on other sites

My XCF leaked oil out the weep hole near the top of the valve cover on the exhaust side. I pulled the valve cover off, cleaned the valve cover gasket, and added some RTV to the seal around the spark plug hole and it solved the issue.

  • Like 1

Share this post


Link to post
Share on other sites
Had the valves checked mechanic saidn they were a little loose, Also added the 8oz flywheel.

took the bike for a short ride this weekend notice oil pumping from the right side of the motor from the weep hole at the top of the the valve cover.

Any input on what went wrong ??

Most likely your valve cover gasket is not sealing or not installed properly. there are several rubber pieces needed to seal the cover. 4 grommets for the cover bolts, 1 rubber gasket for spark plug hole, and valve cover rubber seal itself. . I would NOT recomend silicone on it though. If installed properly it shouldnt leak.

  • Like 1

Share this post


Link to post
Share on other sites
Most likely your valve cover gasket is not sealing or not installed properly. there are several rubber pieces needed to seal the cover. 4 grommets for the cover bolts, 1 rubber gasket for spark plug hole, and valve cover rubber seal itself. . I would NOT recomend silicone on it though. If installed properly it shouldnt leak.

Thanks for the info.

Share this post


Link to post
Share on other sites
Most likely your valve cover gasket is not sealing or not installed properly. there are several rubber pieces needed to seal the cover. 4 grommets for the cover bolts, 1 rubber gasket for spark plug hole, and valve cover rubber seal itself. . I would NOT recomend silicone on it though. If installed properly it shouldnt leak.

Problem solved,Oil leak was the result of the gasket not being checked on the install. (gasket for the spark plug hole)

Share this post


Link to post
Share on other sites

TT members to the rescue once again. I know I wasn't much help but make sure you spread some good gas around for those who did help. Welcome to the orange side.

Share this post


Link to post
Share on other sites

Awesome group for support,hopefully one day I can add some info of Value to the site.

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×