Jump to content
Sign in to follow this  

Clutch assistance needed

Recommended Posts

2004 KX250f, Here is the deal, had a problem with the clutch not completely releasing last fall and difficulty finding neutral with surging in gear with clutch pulled in. After reading tons of posts figured clutch basket was grooved. Tore into it and indeed the basket had some mild marks but the hub was way worse. Long story short is I intended to replace the basket but the flea bay deal turned out to be wrong basket (thanks) so I replaced clutch hub with new, new fibers/plates and springs with tusk kit, new motion pro cable buttoned it up and now it seems worse :) If I try to push the bike backward in gear with the clutch in it feels like its still grabbing and bucking. By the way it does not start acting up until I let the clutch out and then pull it back in. Riding down the street and shifting seem fine, just when stopped.

Not sure how it could be worse than before with added new parts??? I have not had a chance to go give it a good break in ride by any means but the garage test has failed in my opinion. I have adjusted the clutch cable.

Is this simply basket symptoms, plates sticking....??? Help with your thoughts.

Share this post


Link to post
Share on other sites

I have same kind of prob with 05 I read the manual and it talks about ading a nother washer to clutch assy just before you put on pressure plate. It comes with a 1.5 washer and it sayes to put two 1.0 insted to make the realise lever that the cable connects to on the moter sit back a little farther making cable tighter, thats why I think mine isn't releasing all the way my clutch lever is adjusted as far as it can go same with cable. In your case you have replaced it all I would say read threw manual and see if theirs any thing you could have missed. I am interested to find out because I am about to tear mine apart this weakend. If you dont have manual I can send you a web site our look at other clutch threds in kx250f and you will se mine titled clutch rebuild it has a link for the service manual. good luck dude:smirk:

Share this post


Link to post
Share on other sites

I did order the washers and installed them last night thinking the same thing but to no avail. My thoughts are that the new plates have less tolerance (wear) and are exacerbating my symptoms of the basket despite new hub.

Share this post


Link to post
Share on other sites

Figured it out boys and girls. When I popped the gear out of the old basket to install in my new basket that turned out to be the wrong one. I had to re-install the gear into the old basket. When I installed the gear I did not get it seated fully and as a result it left a bit of a gap that put everything else off. Seated it, put everything back in and now she is butter....Just like new.

Share this post


Link to post
Share on other sites

I thought the stock baskets couldn't be reused once the gear was removed.

But then again I havent messed with my 07 and the 05 has an aftermarket one so Duno

Glad to see you're good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×