Jump to content
Sign in to follow this  

ok kx500 peeps!!! help

Recommended Posts

sorry to start a new thread but i didnt think anyone was gonna look at the older one i was posting in before...

so heres the deal, just bought a kx 500 95 model seems to run great starts great seems to have decent power? but like i had said in other posts ..it just didnt seem to be the bike i though it would? ya i can roll past my buddy's 250s if need be, but i was really expecting a wheelie monster and instead it felt fast pulled hard and kinda smooth? so i tore into it tonight...my gearing is 14 in front 48 in rear ..my jetting is 168 main and 60 pilot.. reeds seem good to ...they still have that little pop when you push into them from the back...KIPS seems to be ok? im no expert on it but i didnt see anything weird? seemed to function ok ..although i didnt start it, just took the pipe and side cover off and played around with it...the carb was super clean and free of gunk and crap ..i also checked to make sure there wasnt a fly wheel weight or anything...no weight there...i was just wondering if maybe it needs a top end job?? thats about all that i can think of..even the inside of the pipe was clean as a whistle..i mean it still feels like it has compresion?? you still have to stand and drop on the kick starter.. still takes a decent amount of muscle to push it down with your hand..but i noticed it seemed really easy to turn it over on the flywheel with my hand?? is this normal? i know its a 95 but it doesnt look like it has been ridin alot at all...very good shape...but im pretty sure the top end is stock ...even though 500s dont need top ends as often...hell i dunno maybe it is stupid fast and im just dumb? any input would really help me...thanks alot guys and sorry for the long post!!:)

Share this post


Link to post
Share on other sites

I also have a 95 KX500 I just picked up. I went for a ride and It was slow. I found the clip came of the power valve inside the side cover. Then it was a lot better but I still was not real impressed. My comp is 145-150 cold with throttle open. But my gears are 15/45 and i think it is killing my wheel power.

Share this post


Link to post
Share on other sites

Need to do a compression check.

110-165 is spec, but if on the low side, and it's never been apart... Time to look at the condition of the bore plating, and if the rings are stuck.

The KIPS valves need to be checked for wear on the gears, and the center valve for pin wear.

Not to mention, the crank seals may be toast. A pressure test may need to be done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×