Jump to content
Sign in to follow this  

Anyone with a 2005-2007 KX250? Power valve spring help.

Recommended Posts

I've posted here and on another forum, but so far no luck. My power valve spring broke, and I'm not 100% sure I installed the new one correctly (mainly because I noticed no difference with it in the bike)

There is a machined recess in the power valve cavity to the left of the actuating rod. I assumed it went there, but the spring isn't bent properly to fit there. There is a little wear on the front side of the case, to the right of the rod, where it looks like the spring was resting before. It installs there fine, but it just seems like a really bad design if that's where it goes.

I can take a picture tonight if that will help, but if anyone else has replaced the spring, or knows exactly how it fits, please let me know. Thanks.

Yes, I have the shop manual. It doesn't show proper installation of the spring. Thanks!

Share this post


Link to post
Share on other sites

the Manual states to put the spring as shown and the pic sucks :) however from what I think I see it looks lke the looped part of the spring rest against the motor and the other end of the spring goes in the notch, the cavity in the ce is for a screwdriver to sit while loosening o tightening the kips shaft bold.

so looking into the kips area the cavity is at the let of the kips rod and the looped portio of the spring should sit on the motor at the rightmost , I will try to post a pic

Share this post


Link to post
Share on other sites

2663_60184422524_548652524_2009417_1080218_n.jpg

.Set the spring[A] as shown.

B. Governor shaft

C. Exhaust valve shaft

.Using a 14mm open-end wrench [D], install the governor shaft levr as shown.

.Tighten:

Torque - Governor Shaft Lever Mounting Bolt : 5.9 N.m

note:

put a screw driver (6mm) [F] on the hollow of cylinder as shown to prevent the lever link portion [G]from bending.

.Install the KIPS cover

.Install the removed parts

Share this post


Link to post
Share on other sites

Is this a common problem ? Ive just taken mine apart and my spring is broken as well , it looks like it was broke before i took it apart and the bike has ran fine . Does this mean i can expect to have to replace this spring often then ?

Share this post


Link to post
Share on other sites
Is this a common problem ? Ive just taken mine apart and my spring is broken as well , it looks like it was broke before i took it apart and the bike has ran fine . Does this mean i can expect to have to replace this spring often then ?

Yes!

http://www.thumpertalk.com/forum/showthread.php?p=6919756#post6919756

I replaced mine with a tension spring

Share this post


Link to post
Share on other sites

Since replacing this power valve spring my valves are now making clicking noises when im in the high revs . I have taken the covers off and cant seem to find any reason for this . There is a bit of lateral movment in the exhaust valve shaft and when i open the valves manually i can feel the click as the side valves open . There are no marks or edges for the valves to catch on but i could hear the noise on my last ride . Anybody have any ideas ?

Share this post


Link to post
Share on other sites

Can'T wait to see the answers on this one. I got the same issue on my 2005 kx.Some clicking at high revs, only since i took apart the valves on put them back together.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×