Jump to content
Sign in to follow this  

Crycra Handguard (install)

Recommended Posts

Okay, just received the following:

http://www.motosport.com/dirtbike/product/CYCRA-PRO-BEND-CENTER-REACH-MOUNT-STANDARD-78-BARS/?catalogId=111302&refine=1&sBrand=Cycra&srchHistoryURL=rr4c9se7||parentCategoryID~1^superParentCategoryID~category_root^parentCategoryName~Dirt^categoryID~4^categoryName~Dirt%20Bike%20Parts^subCategoryName~Bars%20and%20Controls^subCategoryID~53@mx8vs9m7||sort_field~Name%20(Ascending)@11kz19f4||refineType~1^sub_attr_name~Brand^refineValue~Cycra

This is for my 07 CRF 450r.

I believe the bars are stock and I can not see how these will mount properly. The bars on my bike are Renthal H971.

The CRM clamp doesn't have enough clearance, it hits the top of the shock clicker. Even if there was enough clearance the CRM clamp does not stick out far enough to meet the guard.

Any insight appreciated. :):banghead::banghead:

Share this post


Link to post
Share on other sites

Looks like you have the CRM (Center Reach Mount) which I am not familiar with. I have the regular ProBend Triple Mount Cycra bars and they do not attach all the way towards the center, they attach to the triple clamps. From the Cycra website, it shows that your CRM setup should mount like this:

yhst-2483094475615_2041_10170724

Here are the ProBend Triple mounts: http://store.cycraracing.com/cypralha.html

Hope this helps!

Share this post


Link to post
Share on other sites

that was the problem, i was looking at the picture and trying to match that.

as soon as i looked at the actual bars and saw the alignment all is good! :)

thanks!

note: when installed on an '07 450R is will not be near the same position as that image.

Share this post


Link to post
Share on other sites

I just had a similar problem trying to install my cycra gaurds. I ordered (PU_06350380GUARD HAND PB U CLAMP STD). I have a 04crf450r, stock bars, clamps...It looks like the u-clamps are to long and dont fit behind the front number plate and the guard u-clamp will not fit due to it hitting the top of the fork tube. I am not sure what the deal is. I might need to order and different model?

Share this post


Link to post
Share on other sites

mine are installed and looking good. i read quite a few threads about installation and they were right "DO NOT tighten anything until aligned"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×