Jump to content
Sign in to follow this  

New engine

Recommended Posts

Hey guys

I have a problem that i hoping someone can shed some light on. I have just finished rebuilding my 06 kx450 well it was about 2 weeks ago at the same time i also pulled the swingarm apart beacause the bearings were shot but the parts took a couple of weeks so the bike was sitting for 2 weeks waiting for the bearings. The parts arrived today so i put the rest of the bike togethor and went to kick it over with my fingers crossed. I got a half a kick out of it and the kickstart locked up. i tried turning the bikeover via the balancer gear and it cranked over smoothly. So im wondering if the problem has something to do with the kicksarter. Any help would be really appreciated

Thanks

Luke

Share this post


Link to post
Share on other sites

Do not kick it through without checking to make sure the KS is installed correctly. You could definately break something.

CR

Share this post


Link to post
Share on other sites

Sounds like a possible cam timing issue. I know you said it turns over by hand via the balance gear , but does it make a complete revolution? My point is, if the cam timing was off and a valve hit the piston when you kicked it then you rotated the engine backwards it would move as if every thing was ok. Try spinning the engine a couple of crank revolutions. If it stops then you have a cam timing problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×