Jump to content
Sign in to follow this  

Rear Flippin Brakes !!!!!!!!!!!!!!!!!!!!!

Recommended Posts

SO I JUST PICKED UP A NEW REDCAT DZ150 YESTERDAY,,,,

rear brakes arent working ,,ive been bleeding for the last 4 hours !!!!!

ive tried every possible way ive found on here,,,except vacuum,,,,

can some one help me out here before i go any more nuts:banghead: :):banghead: :banghead: :foul::p

ive tried to reverse bleed and cant even pump the fluid in !!!!

WHAT THE HELL AM I DOING WRONG !?!?!?!

THEY DONT MOVE AT ALL !!!!!

Share this post


Link to post
Share on other sites

The brake might just not work :) ! Try Chinariders.net and see what the members can help you out with. www.jetmotousa.com has brakes, too, for most Chinese bikes (they are all pretty much the same)

Share this post


Link to post
Share on other sites

The rear brake on one of mine didn't work, like you i bled and bled, still no good.

then a mechanic friend told me to grease the pins on the sliding part of the caliper (under the rubber boots) worked fine after that.

Had just seazed on the pins.

Regards.

Mike.

Share this post


Link to post
Share on other sites

post a pic of this bike, I've had quite a few problems with the brakes on my chinese pitbike.

if you have one with a crf based engine, check your footpeg-bar and brakelever clearence, the bar tends to bend over time, this causes it to depress the brakelever ever so slightly, causing you to eventually lose all pressure.

if the bar is touching the lever, grind a notch in the lever where it contacts the bar, and when you bleed it, LIFT the lever all the way up before you depress it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×